DDOS Mitigation Underway
Resolved
Jun 1, 2026 at 2:11am UTC
The issue impacting Quiddity services has been resolved. We identified the source of the targeted DDoS attack and successfully mitigated it with assistance from federal law enforcement partners. Services have returned to normal operation, and we will continue to monitor the situation to ensure stability.
Affected services
Updated
Jun 1, 2026 at 1:41am UTC
We are currently experiencing a large, targeted DDoS attack affecting Quiddity services. Our team is actively working to mitigate the issue; during this time, users may experience slower load times or intermittent access. We will provide further updates as the situation stabilizes.
Affected services
Updated
May 31, 2026 at 9:08pm UTC
The issue impacting Quiddity services has been resolved. We identified the source of the targeted DDoS attack and successfully mitigated it with assistance from federal law enforcement partners. Services have returned to normal operation, and we will continue to monitor the situation to ensure stability.
Affected services
Created
May 31, 2026 at 7:25pm UTC
We are currently experiencing a large, targeted DDoS attack affecting Quiddity services. Our team is actively working to mitigate the issue; during this time, users may experience slower load times or intermittent access. We will provide further updates as the situation stabilizes.
Affected services